PCTuning
http://pctforum.tyden.cz/

Zjištění kolik dní je ve kterém měsíci mezi dvěma daty EXCEL
http://pctforum.tyden.cz/viewtopic.php?f=53&t=260533
Stránka 2 z 2

Autor:  spider-x [ út 28. listopad 2017, 10:38 ]
Předmět:  Re: Zjištění kolik dní je ve kterém měsíci mezi dvěma daty E

Tak mám nový problém. Potřebuju spočítat součet ubytovacích dnů v měsíci + celkovou částku za všechny hosty v daném měsíci. Snažím se to napasovat do funkce sumifs, ale něják na to nemůžu přijít. Tady je vzorec podle kterého se počítá jaký ubytovací poplatek zaplatí host za dobu svého pobytu.
Kód:
=KDYŽ(NEBO(DATEDIF($E2;$C2;"Y")>=18;DATEDIF($E2;$C2;"Y")<70;$F2<>"ZTP");KDYŽ($D2=1;KDYŽ($C2=$B2;KDYŽ(A(MĚSÍC($B2)>=4;MĚSÍC($B2)<=9);10;5);KDYŽ(MĚSÍC($B2)=MĚSÍC($C2);($C2-$B2)*KDYŽ(A(MĚSÍC($B2)>=4;MĚSÍC($B2)<=9);10;5);(EOMONTH($B2;0)-$B2)*KDYŽ(A(MĚSÍC($B2)>=4;MĚSÍC($B2)<=9);10;5)+DEN($C2)*KDYŽ(A(MĚSÍC($C2)>=4;MĚSÍC($C2)<=9);10;5)));0);0)

Obrázek

Autor:  malli [ út 28. listopad 2017, 12:52 ]
Předmět:  Re: Zjištění kolik dní je ve kterém měsíci mezi dvěma daty E

Nejsem si jistý, jestli správně rozumím zadání, ale např. v buňce K2 (leden) bude součet všech dnů, které se týkají všech hostů v lednu? Je to tak?

A k těm dnům se ještě něco přičítá nebo se něčím násobí nebo co? Nebo ti v tuhle chvíli jde jen o ten počet? Ono to totiž bude zřejmě nejjednodušší, když si tam vložíš 12 (skrytých) sloupců, kde si pro každého hosta spočítáš počet dnů v daném měsíci. No a pak už jen ty jednotlivé sloupce vysčítáš.
Možná to půjde i jednodušeji, ale v tuhle chvíli by to myslím bylo řešení.

BTW: chtělo by to zřejmě ale vyřešit i případy, kdy bude pobyt např. 20.12.2016 - 15.1.2017. Asi nebudeš chtít, aby se ti ty prosincové dny započítaly do prosince 2017.


(A jen pro kontrolu - např. 31.12.2016 - 1.1.2017 je jeden den?)

Autor:  spider-x [ st 29. listopad 2017, 17:13 ]
Předmět:  Re: Zjištění kolik dní je ve kterém měsíci mezi dvěma daty E

Přesně tak jsem to myslel. Počítají se pouze hosté kterým je 18 a víc a míň než 70 a nejsou ZTP a jsou na rekreaci. Podmínky si něják doplním, ale za nic na světě nemůžu přijít na to jak udělat součet jednotlivých měsíců. Vzorcem v jedné buňce, ideálně bez pomocných buněk. Jo a 31.12.2016 - 1.1.2017 je jeden den jak jsi napsal.

Autor:  malli [ st 29. listopad 2017, 17:45 ]
Předmět:  Re: Zjištění kolik dní je ve kterém měsíci mezi dvěma daty E

spider-x napsal:
..., ale za nic na světě nemůžu přijít na to jak udělat součet jednotlivých měsíců. Vzorcem v jedné buňce, ideálně bez pomocných buněk.


Obávám se, že tohle do jednoho vzorce bez pomocných buněk neuděláš.

Stránka 2 z 2 Čas je uváděn v UTC + 1 hodina
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/